Issues logging in and sending messages
Incident Report for Discord
Resolved
Discord is operating at full power and has been since my last update, so we are going to mark this incident as resolved.

The precipitating cause of today's problem was an issue that caused approximately 40 of our servers to go offline simultaneously -- these servers predominantly came from our database clusters.

We apologize for the inconvenience, and appreciate your patience as we worked to restore service this morning.
Posted Nov 09, 2020 - 08:38 PST
Monitoring
At this point, we believe all services have fully recovered and we are monitoring the service to ensure that remains the case.
Posted Nov 09, 2020 - 07:45 PST
Identified
We are seeing some percentage of messages fail to send as we work out the last of the issues here, but the majority of users are back online and using Discord again. We will continue to work through the last issues here to get service back to 100%.
Posted Nov 09, 2020 - 07:31 PST
Update
We are seeing logins and message sends on the rise, showing that traffic is starting to stabilize. We are continuing to work on the recovery and addressing hot spots as we see them.
Posted Nov 09, 2020 - 07:16 PST
Update
We have brought more members of our team online to deal with recovery. We have validated our databases and core chat services, at this point we are restart our API and proxy tiers.
Posted Nov 09, 2020 - 07:06 PST
Update
It looks like there was some kind of power incident at Google, or other major issue. We saw dozens of our servers reboot at the exact same time, so we are currently doing a full system recovery for Discord.
Posted Nov 09, 2020 - 06:54 PST
Investigating
We are aware of some current trouble logging in and sending messagse. The team is online and investigating.
Posted Nov 09, 2020 - 06:31 PST