Increased API Latency, Issues with processing payments
Incident Report for Discord
Resolved
This incident is now resolved.
Posted Jun 04, 2024 - 13:15 PDT
Update
We are investigating a related issue with processing payments as well.
Posted Jun 04, 2024 - 12:40 PDT
Investigating
We are currently investigating an issue impacting API latency
Posted Jun 04, 2024 - 11:56 PDT