Google Pay Outage

Incident Report for Discord

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 09:43 PDT

Identified

We're currently experiencing an issue that prevents users from completing purchases (including Nitro subscriptions and Shop items) through the Android app. This is caused by an ongoing outage with Google Play.

Purchases on other platforms (iOS, web, and desktop) are unaffected, and existing subscriptions remain active.

We're monitoring Google's status and will post an update as soon as service is restored. No action is needed on your part — please try again later.
https://pay.google.com/status/incidents/gQJsjf662F7KwPyiNqav
Posted Sep 16, 2026 - 09:15 PDT