Elevated errors adding payment sources

Incident Report for Discord

Resolved

This incident has been resolved.
Posted Aug 24, 2023 - 15:18 PDT

Investigating

We are currently investigating this issue.
Posted Aug 24, 2023 - 15:15 PDT
This incident affected: Third-party (Tax Calculation Service).