Intermittently high API latency
Incident Report for Discord
Resolved
This incident has been resolved.
Posted Jan 13, 2017 - 11:42 PST
Identified
Over the past few days this incident has been open, we've been working extensively to narrow down and resolve all the issues we believe contributed to these latency spikes. As part of this effort, we've doubled our database capacity for two of our hotter-clusters, worked on tuning the configurations for these clusters to improve performance, and worked on fixing multiple bugs we believe caused hot-spots to appear on these databases. At this point we're still working on rolling these changes out across the board, but we're confident these steps should improve and potentially stifle these issues. As it stands latency and stability have improved drastically, and we've only seen one major latency issue in the past 24 hours. We'll continue to update this status as we complete the roll out of—and monitor—these changes.
Posted Jan 10, 2017 - 12:45 PST
Investigating
We are aware of intermittent increased API latency that occasionally is causing slow/failed message sends, duplicated messages and other issues. We're working on adding more capacity in the needed systems - and hope to have this resolved soon.
Posted Jan 08, 2017 - 12:43 PST