Discord MacOS Desktop Client Crashing
Incident Report for Discord
Resolved
The new version, 0.0.280, is available. If you switched to use Rosetta with the bad version, it's now safe to update and then turn off Rosetta.

If you downloaded the bad version and the app is still crashing for you, please download the update from the website (https://discord.com/api/download?platform=osx).
Posted Oct 05, 2023 - 12:12 PDT
Update
If you've downloaded the bad version, please re-download from the website (https://discord.com/api/download?platform=osx)!
Posted Oct 05, 2023 - 10:59 PDT
Identified
We are aware of an issue causing the newest version of the Discord MacOS desktop client to crash and are working on a fix.
Posted Oct 05, 2023 - 10:44 PDT