Elevated API Latency

Incident Report for Discord

Resolved

We have recovered across all features.
Posted Apr 10, 2025 - 14:01 PDT

Monitoring

All users should now be able to start their session. Various flows might still see elevated latency, but we should be mostly recovered.
Posted Apr 10, 2025 - 13:32 PDT

Identified

We've identified the issue and people are slowly being allowed to start their session again. Working on speeding that up.
Posted Apr 10, 2025 - 13:26 PDT

Investigating

We're investigating elevated api latency across a lot of our endpoints. This is leading to broad impact(sending messages, starting sessions etc)
Posted Apr 10, 2025 - 13:04 PDT