Spurious disconnects from voice servers
Incident Report for Discord
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 16:16 PDT
Monitoring
The fix has been fully deployed and we are monitoring our analytics to confirm that these disconnects subside.
Posted Sep 13, 2024 - 15:59 PDT
Identified
An issue in our previous release of the voice gateway software can cause backend crashes when users disconnect from voice (causing any remaining call members to also disconnect).

We have already partially rolled out a fix for this, but are going to complete that rollout now. Rolling out the fix unfortunately itself requires a reconnect, but once that is complete we expect the spurious disconnects some users have been experiencing to be fully resolved.
Posted Sep 12, 2024 - 23:45 PDT