UK/AU: Issues Completing Age Verification via k-ID

Incident Report for Discord

Resolved

k-ID age verification is operating normally again in the UK and Australia. Previously age verified users were not impacted.
Posted Mar 05, 2026 - 19:49 PST

Monitoring

k-ID has deployed a fix for UK/AU age verification issues. We’re monitoring to ensure age verification is working normally. Previously age verified users should not be impacted.
Posted Mar 05, 2026 - 19:38 PST

Investigating

Some users in the UK and Australia may be unable to complete new age verification via k-ID. Users who have already completed age verification should not be impacted. We’re actively working with k-ID on a resolution and will share updates here as we learn more.
Posted Mar 05, 2026 - 19:26 PST
This incident affected: Client (Desktop, iOS, Android, Web).