API Outage
Incident Report for Discord
Resolved
Things have returned to normal - guilds should re-sync their slash commands incrementally over the next hour.

We apologize for any inconveniences this outage have caused, and our team will be root causing and prioritizing fixes to the underlying failures we observed today.
Posted Jan 26, 2022 - 15:37 PST
Monitoring
We have fully removed all rate limits and Discord is almost back to normal.

Over the next hour, some Discord servers may continue to see some issues interacting with bots using slash commands. As part of resolving the incident, we needed to reduce load on our databases and we turned down some parts of our slash command system.

We are going to complete our internal postmortem process to really dig in and understand exactly what happened here, but we really apologize for the inconvenience if you were unable to login today or had other issues.
Posted Jan 26, 2022 - 14:12 PST
Update
We are down to the last set of offline users and we anticipate everybody being fully online within the next 10 minutes.
Posted Jan 26, 2022 - 13:50 PST
Update
More than half of Discord users are back online and working normally. We continue to work to bring the rest of the users back online.
Posted Jan 26, 2022 - 13:07 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 26, 2022 - 13:06 PST
Update
The database is healthy again and our internal error rate has fallen to nominal levels. We are beginning to raise the login rate limit to allow users to reconnect.
Posted Jan 26, 2022 - 12:29 PST
Update
We are continuing to work through some issues with one of our database clusters. We are still rate limiting login traffic. Next update in 15 minutes.
Posted Jan 26, 2022 - 12:21 PST
Update
We have instituted a rate limit on logins to manage the traffic load. Users who are logged in are successfully using Discord at this point, and we will be slowly raising the limits here to allow more users in as we can. We expect this to be resolved in the next 15 minutes.
Posted Jan 26, 2022 - 12:07 PST
Identified
We have identified the underlying issue with the API outage but are dealing with a secondary issue on one of our database clusters. We have our entire on-call response team online and responding to the issue.
Posted Jan 26, 2022 - 12:03 PST
Investigating
We are currently investigating a widespread API outage.
Posted Jan 26, 2022 - 11:49 PST
This incident affected: API.