New Servers getting accidentally deleted

Incident Report for Discord

Resolved

This incident has been resolved.
Posted Feb 28, 2023 - 18:43 PST

Investigating

We identified the root cause and working on resolving the issue.
Posted Feb 28, 2023 - 18:10 PST