API errors affecting message sends, session starts, and billing operations

Incident Report for Discord

Resolved

We have applied a fix and are seeing recovery across our systems
Posted May 21, 2026 - 20:39 PDT

Identified

We're aware of an issue that is affecting a subset of users trying to interact with our services. We are working on a fix to address the issues.
Posted May 21, 2026 - 18:55 PDT
This incident affected: API.