Users unable to create new Paypal payment methods

Incident Report for Discord

Resolved

This issue has been resolved
Posted Apr 08, 2025 - 14:32 PDT

Monitoring

PayPal API errors have recovered. We are monitoring to ensure the impact has ended
Posted Apr 08, 2025 - 14:22 PDT

Identified

Users are currently unable to add new Paypal payment methods. This appears to be an upstream issue with Paypal's API service. We are monitoring and awaiting resolution.
Posted Apr 08, 2025 - 13:26 PDT
This incident affected: Payments.